Azure Outage Impact
Resolved
Apr 25, 2026 at 1:04am UTC
The Azure incident has been marked as mitigated and our systems look to be back to full health.
We will continue to monitor the situation just in case.
Affected services
Updated
Apr 24, 2026 at 5:02pm UTC
The incident with Azure is still ongoing, causing degradation to our services. However, our systems remain operational and appear to be running as expected at this time.
Our team continues to actively monitor the situation and will take further action as needed.
We appreciate your patience as we work through this disruption.
We will continue to post updates here as more information becomes available.
Affected services
Created
Apr 24, 2026 at 3:41pm UTC
We are currently experiencing service disruptions due to an ongoing Microsoft Azure outage that is affecting our systems. As a result, some payments may be delayed.
Our team is actively investigating the situation and working to minimize the impact. We apologize for any inconvenience this may cause.
We will continue to post updates here as soon as we have more information.
Thank you for your patience.
Affected services