Back to overview
Resolved
Degraded performance in our dashboard
Jul 9, 2026 at 8:31pm UTC
Affected services
Production Dashboard
Resolved
Jul 9, 2026 at 8:45pm UTC
This issue is now resolved. Our identity provider has fixed the problem, and dashboard access is back to normal for all users.
Affected services
Updated
Jul 9, 2026 at 8:42pm UTC
We've confirmed the issue is with our identity provider, which handles sign-in to the dashboard. We're in contact with them to resolve it and will post another update as soon as we have one.
Affected services
Created
Jul 9, 2026 at 8:31pm UTC
We're aware that a small number of users are having trouble accessing the dashboard. We're investigating and will post an update as soon as we know more.
Affected services